25'ten fazla konu seçemezsiniz Konular bir harf veya rakamla başlamalı, kısa çizgiler ('-') içerebilir ve en fazla 35 karakter uzunluğunda olabilir.

68 satır
2.0KB

  1. {
  2. "name": "rdltr-addon",
  3. "version": "0.1.0",
  4. "description": "rdltr firefox addon",
  5. "engines": {
  6. "node": ">=10"
  7. },
  8. "scripts": {
  9. "lint": "eslint --ext .js,.vue src",
  10. "prettier": "prettier \"src/**/*.{js,vue}\"",
  11. "prettier:write": "npm run prettier -- --write",
  12. "build": "cross-env NODE_ENV=production webpack --hide-modules",
  13. "build:dev": "cross-env NODE_ENV=development webpack --hide-modules",
  14. "build-zip": "node scripts/build-zip.js",
  15. "watch": "npm run build -- --watch",
  16. "watch:dev": "cross-env HMR=true npm run build:dev -- --watch"
  17. },
  18. "husky": {
  19. "hooks": {
  20. "pre-commit": "pretty-quick --staged"
  21. }
  22. },
  23. "dependencies": {
  24. "axios": "^0.19.0",
  25. "vue": "^2.6.10",
  26. "vue-multiselect": "^2.1.6",
  27. "webextension-polyfill": "^0.6.0"
  28. },
  29. "devDependencies": {
  30. "@babel/core": "^7.1.2",
  31. "@babel/plugin-proposal-optional-chaining": "^7.0.0",
  32. "@babel/preset-env": "^7.1.0",
  33. "@babel/runtime-corejs3": "^7.4.0",
  34. "archiver": "^3.0.0",
  35. "babel-eslint": "^10.0.3",
  36. "babel-loader": "^8.0.2",
  37. "copy-webpack-plugin": "^5.1.1",
  38. "core-js": "^3.0.1",
  39. "cross-env": "^6.0.3",
  40. "css-loader": "^3.4.0",
  41. "ejs": "^3.0.1",
  42. "eslint": "^6.6.0",
  43. "eslint-config-prettier": "^6.7.0",
  44. "eslint-config-standard": "^14.1.0",
  45. "eslint-friendly-formatter": "^4.0.1",
  46. "eslint-loader": "^3.0.2",
  47. "eslint-plugin-import": "^2.18.2",
  48. "eslint-plugin-node": "^11.0.0",
  49. "eslint-plugin-prettier": "^3.1.1",
  50. "eslint-plugin-promise": "^4.2.1",
  51. "eslint-plugin-standard": "^4.0.1",
  52. "eslint-plugin-vue": "^6.0.1",
  53. "file-loader": "^5.0.2",
  54. "husky": "^3.1.0",
  55. "mini-css-extract-plugin": "^0.9.0",
  56. "node-sass": "^4.9.3",
  57. "prettier": "^1.17.1",
  58. "pretty-quick": "^2.0.1",
  59. "sass-loader": "^8.0.0",
  60. "vue-loader": "^15.4.2",
  61. "vue-template-compiler": "^2.6.10",
  62. "web-ext-types": "^3.2.1",
  63. "webpack": "^4.20.2",
  64. "webpack-cli": "^3.3.10",
  65. "webpack-extension-reloader": "^1.1.0"
  66. }
  67. }